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No part of this document may be
reproduced in any form or by any means
(including electronic storage and retrieval
or translation into a foreign language)
without prior agreement and written
consent from Keysight Technologies, Inc.
as governed by United States and
international copyright laws.

Warranty
The material contained in this document is
provided “as is,” and is subject to being
changed, without notice, in future
editions. Further, to the maximum extent
permitted by applicable law, Keysight
disclaims all warranties, either express or
implied, with regard to this manual and
any information contained herein,
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warranties of merchantability and fitness
for a particular purpose. Keysight shall not
be liable for errors or for incidental or
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the furnishing, use, or performance of this
document or of any information contained
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warranty terms covering the material in
this document that conflict with these
terms, the warranty terms in the separate
agreement shall control.

Technology Licenses
The hardware and/or software described
in this document are furnished under a
license and may be used or copied only in
accordance with the terms of such license.

U.S. Government Rights
The Software is "commercial computer
software," as defined by Federal
Acquisition Regulation ("FAR") 2.101.
Pursuant to FAR 12.212 and 27.405-3 and
Department of Defense FAR Supplement
("DFARS") 227.7202, the U.S. government
acquires commercial computer software

under the same terms by which the
software is customarily provided to the
public. Accordingly, Keysight provides the
Software to U.S. government customers
under its standard commercial license,
which is embodied in its End User License
Agreement (EULA), a copy of which can be
found at
http://www.keysight.com/find/sweula.
The license set forth in the EULA
represents the exclusive authority by
which the U.S. government may use,
modify, distribute, or disclose the
Software. The EULA and the license set
forth therein, does not require or permit,
among other things, that Keysight: (1)
Furnish technical information related to
commercial computer software or
commercial computer software
documentation that is not customarily
provided to the public; or (2) Relinquish
to, or otherwise provide, the government
rights in excess of these rights customarily
provided to the public to use, modify,
reproduce, release, perform, display, or
disclose commercial computer software or
commercial computer software
documentation. No additional
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set forth in the EULA shall apply, except to
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providers of commercial computer
software pursuant to the FAR and the
DFARS and are set forth specifically in
writing elsewhere in the EULA. Keysight
shall be under no obligation to update,
revise or otherwise modify the Software.
With respect to any technical data as
defined by FAR 2.101, pursuant to FAR
12.211 and 27.404.2 and DFARS 227.7102,
the U.S. government acquires no greater
than Limited Rights as defined in FAR
27.401 or DFAR 227.7103-5 (c), as
applicable in any technical data. 52.227-14
(June 1987) or DFAR 252.227-7015 (b)(2)
(November 1995), as applicable in any
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www.ixiacom.com/contact/info

Support
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Regional and local support contacts:

APAC Support +91 80 4939 6410 support@ixiacom.com

Australia +61-742434942 support@ixiacom.com

EMEA Support +40 21 301 5699 support-emea@ixiacom.com

Greater China Region +400 898 0598 support-china@ixiacom.com

Hong Kong +852-30084465 support@ixiacom.com

India Office +91 80 4939 6410 support-india@ixiacom.com

Japan Head Office +81 3 5326 1980 support-japan@ixiacom.com

Korea Office +82 2 3461 0095 support-korea@ixiacom.com

Singapore Office +65-6215-7700 support@ixiacom.com
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Documentation conventions
The following documentation conventions are used in this guide:

Describing interactions with the UI

You can interact with products by using different input methods: keyboard, mouse, touch, and more. So
in most parts of the user documentation, generic verbs have been used that work with any input method.
In cases where input-neutral verbs do not work, mouse-specific verbs are used as the first choice,
followed by touch-specific verbs as the second choice.

See the following table for examples on how you can interpret the different input methods.

Input-neutral Mouse Touch

SelectModify. ClickModify. TapModify.

Select Accounts > Other
accounts > Add an account.

Click Accounts > Other
accounts > Add an account.

Tap Accounts > Other
accounts > Add an account.

To open the document in Outline
view, select View > Outline.

To open the document in Outline
view, click View > Outline.

To open the document in
Outline view, tap View >
Outline.

Select Protocols. Click the Protocols tab. Tap Protocols.

-NA- Double-click the Client wizard. Double-tap the Client wizard.

Open the Packages context
menu.

Right-click Packages to open
the shortcut menu.

Long tap Packages to open the
shortcut menu.

Deprecated words

The following words have been replaced with new words, considering the audience profile, our modern
approach to voice and style, and our emphasis to use input-neutral terms that support all input methods.

Old usage… New usage…

shortcut menu, right-click menu context menu

click, right-click select

drag and drop drag

Documentation conventions
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Conventions Used in this Guide
The following notational conventions are used in this guide.

Text is bolded to highlight important information.

The caution symbol denotes information that is of critical importance to the operation of the NTO.

The electrical hazard symbol indicates that the power supplies in your system may produce high
voltages and energy hazards, which can cause bodily harm.

The hot surface symbol indicates that a surface or component is hot.

The electrostatic discharge (ESD) symbol indicates proper antistatic precautions should be taken
to avoid damaging electronic equipment including printed circuit boards and components that are
sensitive to static electricity.

The pointer symbol indicates that the information that follows provides helpful tips on how to use
and configure the XGS chassis.

Note: Notes are written like this.

Conventions Used in this Guide

– vi –



CHAPTER 1 Purpose and Upgrade Process
Outline
This document describes the steps needed upgrade an Ixia XGS Chassis to Windows 10.

The first step in the upgrade process is to back up and replace the XGS Chassis Windows 7 OS partition
with an Ixia XGS Chassis Windows 10 base image. The Data partition with Acronis backup images are not
affected.
The following is an outline of the steps required to accomplish this upgrade task:

l Create an Acronis Recovery Image
l Replace the XGS Chassis Windows 7 partition with an XGS Chassis Windows 10 partition
l Windows 10 first-boot procedure
l Windows 10 Activation
l IxOS 9.00 Installation
l IxOS Windows 10 Upgrade License Activation

Note:
l Ensure this Upgrade Guide is available on another system or printed since it will not be
available during portions of the upgrade process.

l The upgrade requires IxOS 9.00 or later version.
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CHAPTER 2 Prerequisites
The following are the prerequisites for upgrading an Ixia XGS Chassis to Windows 10:

l Check to ensure you have the upgrade product 943-0014 IXIA IXOS AND WINDOWS 10 FIELD
UPGRADE which includes the USB and Windows 10 license sticker.

l Check that the chassis to be upgraded is an XGS 940-0010, 940-0011 or 940-0110.

Note: The XGS-SD chassis has 2x USB-ports only.

l Ensure there is physical access to the chassis to be upgraded.
l Ensure that a monitor, keyboard, and mouse are available.
l Obtain the license activation key that is emailed as part of purchase of upgrade product 943-0014.
l Print or display these instructions on another system since the system being upgraded will not be
available for document viewing.

l You need to de-register the current licenses before starting the Windows 10 upgrade. See the
following De-activate Ixia licenses section.

De-activate Ixia licenses

Ixia Licensing Utility (ILU) manages the licenses issued by Ixia for its various products.
Using the ILU, deactivate all your licenses from the chassis and save your receipt file to store all activation
codes. Move a copy of the receipt file to the Data partition.
See also Deactivate Licenses section of the Ixia Licensing Management Guide.

Note down local settings for reconfiguration after reimage

Disk reimage will delete all existing settings such as IP addresses and proxy servers. Note down the
following to reconfigure after reimage:

l IP Address (or DHCP configuration)
l DNS address
l Any Proxy server settings
l Username and password.

Note: Always use username as'ixia'. After the reimage, password will be set to the default,
which is the 6-digit serial number of the controller.

l Any specific firewall or virus scanning software required by your IT department.

Chapter 2  Prerequisites
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CHAPTER 3 Change password
You can change password by one of the following methods:

1st method

Press Ctrl + Alt + Del and then select Change password

2nd method

Go to Start > Control Panel > User Accounts > Manage User Accounts > Change An Account > Change
password

3rd method

Start > Control Panel > View By > Large Icons > Administrative Tools > Computer Management > Local
Users And Groups > Users. Select Set Password from the context menu.

4th method

Start- > Settings > Accounts > Sign-in options. Select Password and select Change.

No further action is required if you change the password by 1st, 2nd, or 3rd method. If you change it by
the 4th method, you must configure the new password in Microsoft's netplwiz as shown in the following
steps:

1. Go to Run and type regedit.exe

2. Configure AutoAdminLogon to 1 in registry editor – HKEY_LOCAL_
MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

3. Go to Run and open netplwiz.

Chapter 3  Change password
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4. Clear Users must enter a user name and password to use this computer check box and
then select Apply.

5. Type the default user name and the new password for automatic sign in process and select OK.

Chapter 3  Change password
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6. Restart your computer to ensure the automatic sign in works seamlessly.

Chapter 3  Change password
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CHAPTER 4 Procedures
The procedures for Windows 10 field upgrade are described in the following sections.

WARNING: IxOS version 9.00 or later is required to run Ixia hardware on Windows 10. If you still
need to run earlier versions of software, do not proceed with the upgrade to Windows 10.

If at a later date you need to revert the chassis to Windows 7, you will need to contact Support to have a
clean Windows 7 image installed on the chassis.

Windows 10 Upgrade Using Partition Replacement
Procedure
The Windows 10 partition replacement procedure is outlined as follows:

1. Ensure all user data has been moved to the Data partition. All data in the “Windows7” partition will
be overwritten.

2. Ensure an Acronis image backup is available.

3. During chassis boot, press DEL to enter Setup. (Repeatedly press DEL while the Ixia logo is shown.)

4. If an Enter Password prompt appears, leave the prompt blank and press ENTER.

5. In the Aptio Setup Utility, navigate to the Save & Exit tab.

Chapter 4  Procedures
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6. Under the Boot Override section, select the USB device (“SanDisk” in this example.)

Note: DO NOT select the UEFI boot option.

Chapter 4  Procedures
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7. The screen should go black and display “Press any key to boot from USB”. Press ENTER.

8. On theWindows Boot Manager screen, press ENTER to selectWindows Setup. This is an
optional step.

Chapter 4  Procedures
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Note: This option is not seen during some installations.

9. Windows PE will now boot. Wait for the progress bar to complete.

10. Once Windows PE has booted, the following command prompt will automatically appear. Wait for the
operation to finish.

Chapter 4  Procedures
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11. A prompt appears with the line “Ixia Windows 10 Chassis Upgrade”, asking to confirm that the
Windows partition will be erased.
Ensure all data is backed up. When ready, press any key to begin.

12. Wait for Ghost to complete rewriting the Windows partition. Once complete, it restarts
automatically.

13. Ensure the system reboots into Windows 10.

14. The system may spend several minutes preparing the desktop, which may require several reboots.
Ensure the Windows 10 login prompt appears.

15. Accept Microsoft EULA.

Note: When booting for the first time, the menu item in Windows Boot Manager may still say
“Windows 7”. This does not indicate a failed upgrade and is corrected at the next step.

Windows 10 First-Boot Procedure
1. Wait until the account completes first-time configuration. The desktop should appear within several

minutes.

2. When prompted, enter the 6-digit serial number of the Standard Performance Controller Module and
press Enter.
The serial number is printed on the label at the front of each controller.

3. The script makes the necessary changes and reboots.

4. After the computer reboots successfully, the chassis is ready for installation of Ixia software.

Note: After the system reboots, you can log in as the ixia user. The password will be the 6-digit
serial number you entered earlier.

Windows 10 License Activation
1. Obtain the Windows 10 license key from the label in the upgrade kit.

2. Navigate to Start > Settings > Update & Security > Activation.

3. Select Change product key.

4. Enter the product key and then select Next to complete activation. This step requires connection to
the internet to complete the Microsoft license activation.

Note: After you activate the license, do a power down, pull out the controller card, apply the
license sticker, and insert the controller back.

For additional information, visit https://support.microsoft.com/en-us/help/12440/windows-10-activate.

Installation of IxOS 9.00 or later
Download a copy of IxOS installer (.exe file) from Ixia website.

IxOS installer installs IxExplorer and server components like Demo Server, TCL Server, and Hardware
Manager.

Perform the following installation steps:

Chapter 4  Procedures
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1. A dialogue box appears providing option for changing Installer Cache path where installer and
helper files are stored. You should change it to a location which does not require administrative
privileges. Select Next to proceed.

2. Installer starts unpacking files after which, setup progress window appears and package integrity
check is performed. Wait for the check to complete.

3. After package integrity check passes, a separate welcome dialog box appears indicating that setup
is ready to begin. Select Next to proceed with the installation. The setup wizard guides you through
the next steps.

Note: If you intend to use IxNetwork or IxLoad please download and install the chassis
components of these products.

For downloading the installer files, go to https://support.ixiacom.com/ixos-software-downloads-
documentation.

For details on Windows 10 installation procedure, see IxOS Getting Started Guide at
https://support.ixiacom.com/user-guide/ixos.

IxOS Windows 10 Upgrade License Activation
Ixia Licensing Utility (ILU) manages the licenses issued by Ixia for its various products.
To open the ILU application, select Start > All Programs > Ixia > LicenseServerPlus > Ixia Licensing
Utility.

Perform the following steps:

1. Select Activate and add all the licenses (example for IxOS, IxNetwork, and IxLoad), that you
deactivated prior to the Windows 10 upgrade. This license information should be in the receipt file
you saved to the data partition before the Windows upgrade.

2. Additionally, add the new Ixia IxOS and Windows 10 Field Upgrade license that was emailed to
you when this product was ordered.

For details on activating licenses, see Ixia Licensing Utility Guide.

Chapter 4  Procedures
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Revision Policy
817-1019-01 Windows 10 Reimage from Windows 7, Revert Chassis

This document shall be controlled, approved, distributed, and revised electronically through Document
Control.

Confidentiality
817-1019-01 Windows 10 Reimage from Windows 7, Revert Chassis

THIS DOCUMENT AND THE DATA DISCLOSED HEREIN OR HEREWITH IS PROPRIETARY AND IS NOT TO
BE REPRODUCED, USED OR DISCLOSED IN WHOLE OR IN PART TO ANYONE WITHOUT THE WRITTEN
PERMISSION OF IXIA COMMUNICATIONS. COPYRIGHT, © IXIA 2009
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