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Documentation conventions

Documentation conventions

The following documentation conventions are used in this guide:

Describing interactions with the UI

You can interact with products by using different input methods: keyboard, mouse, touch, and more. So
in most parts of the user documentation, generic verbs have been used that work with any input method.
In cases where input-neutral verbs do not work, mouse-specific verbs are used as the first choice,
followed by touch-specific verbs as the second choice.

See the following table for examples on how you can interpret the different input methods.

Input-neutral
Select Modify.

Select Accounts > Other
accounts > Add an account.

To open the document in Outline
view, select View > Outline.
Select Protocols.

_NA_

Open the Packages context
menu.

Deprecated words

Mouse
Click Modify.

Click Accounts > Other
accounts > Add an account.

To open the document in Outline
view, click View > Outline.

Click the Protocols tab.

Double-click the Client wizard.

Right-click Packages to open
the shortcut menu.

Touch
Tap Modify.

Tap Accounts > Other
accounts > Add an account.

To open the documentin
Outline view, tap View >
Outline.

Tap Protocols.
Double-tap the Client wizard.

Long tap Packages to open the
shortcut menu.

The following words have been replaced with new words, considering the audience profile, our modern
approach to voice and style, and our emphasis to use input-neutral terms that support all input methods.

Old usage...
shortcut menu, right-click menu
click, right-click

drag and drop

New usage...
context menu
select

drag

—jv -
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Conventions Used in this Guide

Conventions Used in this Guide

The following notational conventions are used in this guide.

Text is bolded to highlight important information.
A The caution symbol denotes information that is of critical importance to the operation of the NTO.

& The electrical hazard symbol indicates that the power supplies in your system may produce high
voltages and energy hazards, which can cause bodily harm.

@ The hot surface symbol indicates that a surface or component is hot.

& The electrostatic discharge (ESD) symbol indicates proper antistatic precautions should be taken
to avoid damaging electronic equipment including printed circuit boards and components that are
sensitive to static electricity.

The pointer symbol indicates that the information that follows provides helpful tips on how to use
and configure the XGS chassis.

F_| Note: Notes are written like this.

- Vi -



CHAPTER 1 Purpose and Upgrade Process
Outline

This document describes the steps needed upgrade an Ixia XGS Chassis to Windows 10.

The first step in the upgrade process is to back up and replace the XGS Chassis Windows 7 OS partition
with an Ixia XGS Chassis Windows 10 base image. The Data partition with Acronis backup images are not
affected.

The following is an outline of the steps required to accomplish this upgrade task:

@

Create an Acronis Recovery Image

Replace the XGS Chassis Windows 7 partition with an XGS Chassis Windows 10 partition
Windows 10 first-boot procedure

Windows 10 Activation

IxOS 9.00 Installation

IxOS Windows 10 Upgrade License Activation

Note:
¢ Ensure this Upgrade Guide is available on another system or printed since it will not be

available during portions of the upgrade process.

e The upgrade requires IxOS 9.00 or later version.
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Chapter 2 Prerequisites

CHAPTER 2 Prerequisites

The following are the prerequisites for upgrading an Ixia XGS Chassis to Windows 10:

Check to ensure you have the upgrade product 943-0014 IXIA IXOS AND WINDOWS 10 FIELD
UPGRADE which includes the USB and Windows 10 license sticker.

Check that the chassis to be upgraded is an XGS 940-0010, 940-0011 or 940-0110.
LT_| Note: The XGS-SD chassis has 2x USB-ports only.

Ensure there is physical access to the chassis to be upgraded.
Ensure that a monitor, keyboard, and mouse are available.
Obtain the license activation key that is emailed as part of purchase of upgrade product 943-0014.

Print or display these instructions on another system since the system being upgraded will not be
available for document viewing.

You need to de-register the current licenses before starting the Windows 10 upgrade. See the
following De-activate Ixia licenses section.

De-activate Ixia licenses

Ixia Licensing Utility (ILU) manages the licenses issued by Ixia for its various products.

Using the ILU, deactivate all your licenses from the chassis and save your receipt file to store all activation
codes. Move a copy of the receipt file to the Data partition.

See also Deactivate Licenses section of the Ixia Licensing Management Guide.

Note down local settings for reconfiguration after reimage

Disk reimage will delete all existing settings such as IP addresses and proxy servers. Note down the
following to reconfigure after reimage:

IP Address (or DHCP configuration)
DNS address
Any Proxy server settings

Username and password.

i| Note: Always use username as'ixia'. After the reimage, password will be set to the default,
which is the 6-digit serial number of the controller.

Any specific firewall or virus scanning software required by your IT department.
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Chapter 3 Procedures

CHAPTER 3 Procedures

The procedures for Windows 10 field upgrade are described in the following sections.

A WARNING: IxOS version 9.00 or later is required to run Ixia hardware on Windows 10. If you still
need to run earlier versions of software, do not proceed with the upgrade to Windows 10.

If at a later date you need to revert the chassis to Windows 7, you will need to contact Support to have a
clean Windows 7 image installed on the chassis.

Windows 10 Upgrade Using Partition Replacement
Procedure

The Windows 10 partition replacement procedure is outlined as follows:

1. Ensure all user data has been moved to the Data partition. All data in the "Windows7"” partition will
be overwritten.

2. During chassis boot, press DEL to enter Setup. (Repeatedly press DEL while the Ixia logo is shown.)

IXlad

3. If an Enter Password prompt appears, leave the prompt blank and press ENTER.

4. 1Inthe Aptio Setup Utility, navigate to the Save & Exit tab.
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5. Under the Boot Override section, select the USB device ("SanDisk” in this example.)

Aptio Setup Utility - Copyright (C) 2014 American Megatrend

SanDisk

@ Note: DO NOT select the UEFI boot option.

6. The Windows icon appears indicating that it is starting up.

7. While Windows loads the script, it pauses for some time showing “wpeinit”.

XA\windows\system32\crmd.exe - startnet.cond

X:\windows\system32>wpeinit
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8. The following menu appears. For Windows 10 upgrades, type “1” on the keyboard.

X:A\windows\system32\cmd.exe - startnet.cnd

- Windows 10 Upgrade (XGSSD Only)
- Clean Install
- Additional Options

hoose option:

=== WARNING ---

This upgrade is i

r or Wi

Before continuing, ens::ex$:SD o2y
- THIS wILL ERASE ALL DATA ON

€ Windows partitio
n h
THE WINDOWS PARTITION oo Packed up.

Continue [Y.n]2

10. The Ghost process starts loading the new image.

11. Wait for Ghost to complete rewriting the Windows partition. Once complete, it restarts

automatically.
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12.
13.

14.

Ensure the system reboots into Windows 10.

The system may spend several minutes preparing the desktop, which may require several reboots.
Ensure the Windows 10 login prompt appears.

Accept Microsoft EULA.

i| Note: When booting for the first time, the menu item in Windows Boot Manager may still say
“Windows 7”. This does not indicate a failed upgrade and is corrected at the next step.

Windows 10 First-Boot Procedure

1.

Wait until the account completes first-time configuration. The desktop should appear within several
minutes.

When prompted, enter the 6-digit serial number of the Standard Performance Controller Module
prefixed by XGSSD (example: XGSSD-xxxxxx), and press Enter.
The serial number is printed on the label at the front of each controller.

3. The script makes the necessary changes and reboots.

4. After the computer reboots successfully, the chassis is ready for installation of Ixia software.

(i

Note: After the system reboots, you can log in as the ixia user. The password will be the 6-digit
serial number you entered earlier.

Windows 10 License Activation

sl S

Obtain the Windows 10 license key from the label in the upgrade kit.
Navigate to Start > Settings > Update & Security > Activation.
Select Change product key.

Enter the product key and then select Next to complete activation. This step requires connection to
the internet to complete the Microsoft license activation.

Note: After you activate the license, do a power down, pull out the controller card, apply the
license sticker, and insert the controller back.

For additional information, visit https://support.microsoft.com/en-us/help/12440/windows-10-activate.

Installation of Ix0OS 9.00 or later

Download a copy of IxOS installer (.exe file) from Ixia website.

IxOS installer installs IXExplorer and server components like Demo Server, TCL Server, and Hardware
Manager.

Perform the following installation steps:

1.

A dialogue box appears providing option for changing Installer Cache path where installer and
helper files are stored. You should change it to a location which does not require administrative
privileges. Select Next to proceed.


https://support.microsoft.com/en-us/help/12440/windows-10-activate
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2. Installer starts unpacking files after which, setup progress window appears and package integrity
check is performed. Wait for the check to complete.

3. After package integrity check passes, a separate welcome dialog box appears indicating that setup
is ready to begin. Select Next to proceed with the installation. The setup wizard guides you through
the next steps.

LT_| Note: If you intend to use IxNetwork or IxLoad please download and install the chassis
components of these products.

For downloading the installer files, go to https://support.ixiacom.com/ixos-software-downloads-
documentation.

For details on Windows 10 installation procedure, see IxOS Getting Started Guide at
https://support.ixiacom.com/user-guide/ixos.

IxOS Windows 10 Upgrade License Activation

Ixia Licensing Utility (ILU) manages the licenses issued by Ixia for its various products.
To open the ILU application, select Start > All Programs > Ixia > LicenseServerPlus > Ixia Licensing
Utility.

Perform the following steps:
1. Select Activate and add all the licenses (example for IxOS, IxNetwork, and IxLoad), that you

deactivated prior to the Windows 10 upgrade. This license information should be in the receipt file
you saved to the data partition before the Windows upgrade.

2. Additionally, add the new Ixia IxOS and Windows 10 Field Upgrade license that was emailed to
you when this product was ordered.

License Server |P/Host Name Host Id ‘:D:' % o ,\_| oy
. o
localhost | 01342b-b5ffoe-ceffd5-b3c8 —! b
Activate Deactivate Sync Offline
License Statistics | License License Operations Tools
View Licenses:
By Product ~ ™[] show bundles part numbers | Expand Al | | Collapse Al
= Part Number Description License Expiration Maintenance Expiration Quantity Activation Code
4 Product: Ix05
» 922-0001-02 IXIA FRAMEWORK (IxServer), IXOS SOFTWARE, NODE-LOCKE... 09-Jun-2019 09-Jun-2019 1 1A1B-E11D-E917-3BDF
[[] 943-0014-01 IXIA IXOS AND WINDOWS 10 FIELD UPGRADE for XGS prod... 27-Nov-2019 27-Nov-2019 1 BE28-567B-6C0A-2524

For details on activating licenses, see Ixia Licensing Utility Guide.
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CHAPTER 4 Change password

You can change password by one of the following methods:

1st method

Press Ctrl + Alt + Del and then select Change password

2nd method

Go to Start > Control Panel > User Accounts > Manage User Accounts > Change An Account > Change
password

3rd method

Start > Control Panel > View By > Large Icons > Administrative Tools > Computer Management > Local
Users And Groups > Users. Select Set Password from the context menu.

4th method

Start- > Settings > Accounts > Sign-in options. Select Password and select Change.

No further action is required if you change the password by 1st, 2nd, or 3rd method. If you change it by
the 4th method, you must configure the new password in Microsoft's netplwiz as shown in the following
steps:

Go to Run and type regedit.exe

2. Configure AutoAdminLogon to 1 in registry editor - HKEY_LOCAL_
MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

3. Go to Run and open netplwiz.

=i Type the name of a program, folder, document, or Internet
= resource, and Windows will open it for you.

Open: netplwiz W

K Cancel Browse...

-11 -



Chapter 4 Change password

4. Clear Users must enter a user name and password to use this computer check box and
then select Apply.

Usrs  Advanced

Use the list Delow o grant Or deny users access 1o your
computer, and to change passwords and other settings

I:'li.}r-ers must gnter a user name and password o use this computer.

Lsers for this computén

LI Marme Ghoup

Add Remaowe Properties

Password for Instrument

g To change your password, press Ctri-Alt-Del and select
Change Password.

Reset Passwond_.

L
[ o« | concel  sepy

5. Type the default user name and the new password for automatic sign in process and select OK.

-12 -



Chapter 4 Change password

Automatically sign in

User name:

Password:

Confirm Passwornd:

Instrument

You can st up your computer S0 that users do not have o type a
user name and password 10 sign in. To do this, specify a user that
will be automatically sigred in below:

0K

iCancel

6. Restart your computer to ensure the automatic sign in works seamlessly.

-13 -
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