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Notices
Copyright Notice
© Keysight Technologies 2017–2023

No part of this document may be repro-
duced in any form or by any means (includ-
ing electronic storage and retrieval or
translation into a foreign language) without
prior agreement and written consent from
Keysight Technologies, Inc. as governed by
United States and international copyright
laws.

Warranty
The material contained in this document is
provided “as is,” and is subject to being
changed, without notice, in future editions.
Further, to the maximum extent permitted
by applicable law, Keysight disclaims all war-
ranties, either express or implied, with
regard to this manual and any information
contained herein, including but not limited
to the implied warranties of merchantability
and fitness for a particular purpose.
Keysight shall not be liable for errors or for
incidental or consequential damages in con-
nection with the furnishing, use, or per-
formance of this document or of any
information contained herein. Should
Keysight and the user have a separate writ-
ten agreement with warranty terms cov-
ering the material in this document that
conflict with these terms, the warranty
terms in the separate agreement shall con-
trol.

Technology Licenses
The hardware and/or software described in
this document are furnished under a license
and may be used or copied only in accord-
ance with the terms of such license.

U.S. Government Rights
The Software is "commercial computer soft-
ware," as defined by Federal Acquisition
Regulation ("FAR") 2.101. Pursuant to FAR
12.212 and 27.405-3 and Department of
Defense FAR Supplement ("DFARS")
227.7202, the U.S. government acquires
commercial computer software under the
same terms by which the software is cus-
tomarily provided to the public. Accordingly,

Keysight provides the Software to U.S. gov-
ernment customers under its standard com-
mercial license, which is embodied in its End
User License Agreement (EULA), a copy of
which can be found at http://www.key-
sight.com/find/sweula. The license set forth
in the EULA represents the exclusive author-
ity by which the U.S. government may use,
modify, distribute, or disclose the Software.
The EULA and the license set forth therein,
does not require or permit, among other
things, that Keysight: (1) Furnish technical
information related to commercial com-
puter software or commercial computer
software documentation that is not cus-
tomarily provided to the public; or (2) Relin-
quish to, or otherwise provide, the
government rights in excess of these rights
customarily provided to the public to use,
modify, reproduce, release, perform, dis-
play, or disclose commercial computer soft-
ware or commercial computer software
documentation. No additional government
requirements beyond those set forth in the
EULA shall apply, except to the extent that
those terms, rights, or licenses are explicitly
required from all providers of commercial
computer software pursuant to the FAR and
the DFARS and are set forth specifically in
writing elsewhere in the EULA. Keysight
shall be under no obligation to update,
revise or otherwise modify the Software.
With respect to any technical data as
defined by FAR 2.101, pursuant to FAR
12.211 and 27.404.2 and DFARS 227.7102,
the U.S. government acquires no greater
than Limited Rights as defined in FAR
27.401 or DFAR 227.7103-5 (c), as applic-
able in any technical data. 52.227-14 (June
1987) or DFAR 252.227-7015 (b)(2) (Novem-
ber 1995), as applicable in any technical
data.

Safety Information

Do not proceed beyond a hazard notice
until the indicated conditions are fully
understood and met.

A CAUTION notice denotes a hazardous
situation that, if not avoided, could res-
ult in minor or moderate injury.

AWARNING notice denotes a haz-
ardous situation that, if not avoided,
could result in death or serious injury.
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Contacting Us

Keysight headquarters
1400 Fountaingrove Parkway
Santa Rosa, CA 95403-1738
www.ixiacom.com/contact/info

Support

Global Support +1 818 595 2599 support@ixiacom.com

Regional and local support contacts:

APAC Support +91 80 4939 6410 support@ixiacom.com

Australia +61-742434942 support@ixiacom.com

EMEA Support +40 21 301 5699 support-emea@ixiacom.com

Greater China Region +400 898 0598 support-china@ixiacom.com

Hong Kong +852-30084465 support@ixiacom.com

India Office +91 80 4939 6410 support-india@ixiacom.com

Japan Head Office +81 3 5326 1980 support-japan@ixiacom.com

Korea Office +82 2 3461 0095 support-korea@ixiacom.com

Singapore Office +65-6215-7700 support@ixiacom.com

Taiwan (local toll-free number) 00801856991 support@ixiacom.com
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Documentation conventions
The following documentation conventions are used in this guide:

Describing interactions with the UI

You can interact with products by using different input methods: keyboard, mouse, touch, and more.
So in most parts of the user documentation, generic verbs have been used that work with any input
method. In cases where input-neutral verbs do not work, mouse-specific verbs are used as the first
choice, followed by touch-specific verbs as the second choice.

See the following table for examples on how you can interpret the different input methods.

Input-neutral Mouse Touch

SelectModify. ClickModify. TapModify.

Select Accounts > Other
accounts > Add an account.

Click Accounts > Other
accounts > Add an account.

Tap Accounts > Other
accounts > Add an
account.

To open the document in
Outline view, select View >
Outline.

To open the document in
Outline view, click View >
Outline.

To open the document in
Outline view, tap View >
Outline.

Select Protocols. Click the Protocols tab. Tap Protocols.

-NA- Double-click the Client wizard. Double-tap the Client wizard.

Open the Packages context
menu.

Right-click Packages to open
the shortcut menu.

Long tap Packages to open
the shortcut menu.

Deprecated words

The following words have been replaced with new words, considering the audience profile, our
modern approach to voice and style, and our emphasis to use input-neutral terms that support all
input methods.

Old usage... New usage...

shortcut menu, right-click menu context menu

click, right-click select

drag and drop drag

Documentation conventions
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About this guide
This section explains the notational and typographical conventions used in this documentation, and
provides a list of related documentation.

Section contents:

Note icons and messages 2

Typographical conventions 2

Textual conventions 3
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Note icons and messages
The following table describes the note icons and messages used in this document.

Name Icon Description

Note Indicates information that emphasizes or supplements important points in
the main text.

Important Indicates information that is essential to the completion of a task.

Tip Provides supplemental suggestions for applying techniques and
procedures to accomplish a task.

Typographical conventions
The following table describes the typographical conventions used in this document.

Convention Description

bold text Bold text indicates:
l Graphical user interface element names (such as dialog boxes, buttons,
menu selections, and so forth).

l Command line interface commands and options.
l The name of a field, option, or parameter when used as part of an
instruction.

For example: “Select the desired Inner Priority value.”

Italic text Italic text indicates:
l A text reference to the name of a field, option, or parameter.
l Document and book titles.
l The first reference to a new term.
l Special identification or emphasis in a statement.

monospace
text

Text shown in a monospace font is used to indicate:
l Text that you input. For example:

Enter cd project1

l Code samples, including keywords and variables within text and as separate
paragraphs, and user-defined program elements within text.

l Text file content or examples, such as lines of text from an .ini file.

About this guide
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Textual conventions
The following table describes the typographical conventions used in this document.

Convention Description

Boolean text Words that represent Boolean notation are written in all uppercase text.

For example: 192.168.5.5 OR 10.20.30.30.

Keystrokes Simultaneous keystrokes are shown by joining the key names with a plus
sign (+).

For example, CTRL+Q.

> (right angle
bracket)

Separates levels in a hierarchy of menu selections.

For example: “Select Administration > Users.”

About this guide
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CHAPTER 1
Ixia Application Server Installation

Note Regarding Ixia Applications
The Ixia Application Server does not have Ixia applications pre-installed.

In order to support Ixia applications, the client component of Ixia applications used must be installed
on the Ixia Application Server. For Ixia application compatibility and support, please visit
www.ixiacom.com (under Support, choose Product Compatibility Matrix ).

Supported Applications
l IxAutomate 6.90 GA SP1, or later version
l IxLoad 5.10 GA, or later version
l IxN2X 6.13 GA, or later version
l IxNetwork 5.70 EA Patch 2, or later version
l IxOS 5.70 EA SP2 Client, or later version

A downloadable version of the applications are available at www.ixiacom.com (under Support,
Downloads & Updates).

Overview and Specifications

The Ixia Application Server is a high-end dual-processor, 1U rack-mount server with state-of-the-art
features. It optimizes and enhances Ixia test application performance by running Ixia applications,
in a server-based environment. Connection via Microsoft's remote desktop (RDT) facility provides
access to the test applications on the server, minimizing client requirements. The Ixia Application
Server centralizes application updates and installation, simplifying test-environment management.

Figure: 1U Multi-User Application Server

Specifications are detailed in Table: Specifications.
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Table: Specifications

Ixia Application Server

Motherboard Dual-processor motherboard using Intel C610-series chipset.

Processor 2 x Intel Xeon processor E5-2600 v3 product family.

Memory 64GB RDIMM, 2133 MT/s, Dual Rank.

Drives One 1TB SATA 6Gbps 3.5 inch hot-plug hard-drive

One 480GB Solid State Drive 6Gbps 2.5 inch hot-plug drive

I/O Ports Rear panel ports: COM port, VGA port, USB and USB 3.0 ports

Front panel ports: VGA port, DVD drive

Ethernet Ports 4 x 1 Gigabit Ethernet ports.

System Power 2 x 550W power supply units, 100-240VAC, 50/60Hz, 3.7A-7.4A.

Control Panel LEDs indicate power on, network activity, hard disk drive activity, overheat
warning, and fan failure; control panel also includes a main power button and a
reset button.

Cooling
System

6x high-efficiency fans.

Physical Dimensions (WxHxD) 17.2 x 1.7 x 25.4 in. (437 x 43 x 645 mm)

Weight: 27 lbs (12.25 kg), Shipping Weight: 47.45 lbs (21.7 kg)

Operating
Environment

Up to 35°C (95°F) maximum temperature is reduced by 1°C/300m (1°F/547 ft)
above 950m (3,117 ft).

Operating
System

Microsoft Windows Server 2012 64-bit Standard Edition with 10 remote desktop
user licenses.

Rackmount Kit Rails for tool-less mounting in 4-post racks with square or unthreaded round
holes, or tooled mounting in 4-post threaded hole racks, with support for optional
tool-less cable management arm.

Application
Support

10 Users on the following applications:

IxNetwork

IxLoad

IxOS

Chapter 1  Ixia Application Server Installation
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Installation and Setup
Overview

This section provides a quick setup checklist to get your Ixia Application Server up and running.
Follow the steps in the order given to get the system operational within a minimum amount of time.
This quick setup assumes that your system has come to you with the processors and memory pre-
installed. If your system is not already fully integrated with a serverboard, processors, and system
memory, turn to the chapter or section noted in each step for details on installing specific
components.

Unpacking the System

Inspect the box the Ixia Application Server was shipped in and note if it was damaged in any way. If
the server itself shows damage you should file a damage claim with the carrier who delivered it.
Decide on a suitable location for the rack unit that will hold the Ixia Application Server. It should be
situated in a clean, dust-free area that is well ventilated. Avoid areas where heat, electrical noise and
electromagnetic fields are generated. You will also need it placed near a grounded power outlet. Read
the Rack and Server Precautions in the next section.

Preparing for Setup

The shipment box of the Ixia Application Server should include two sets of rail assemblies, two rail
mounting brackets, and the mounting screws needed to install the system into the rack. Read this
section in its entirety before you begin the installation procedure outlined in the sections that follow.

Choosing a Setup Location
l Leave enough clearance in front of the rack to allow you to open the front door completely (~25
inches) and approximately 30 inches of clearance in the back of the rack to allow for sufficient
airflow and ease in servicing. This product is suitable for installation only in a Restricted Access
Location (dedicated equipment rooms and service closets).

l This product is not suitable for use with visual display work place devices according to §2 of the
German Ordinance for Work with Visual Display Units.

Rack Precautions

l Ensure that the leveling jacks on the bottom of the rack are fully extended to the floor with the
full weight of the rack resting on them.

l In single rack installation, stabilizers should be attached to the rack. In multiple rack
installations, the racks should be grouped together.

l Always make sure the rack is stable before extending a component from the rack.
l You should extend only one component at a time. Extending two or more components
simultaneously may cause the rack to become unstable.

Chapter 1  Ixia Application Server Installation
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Installer Precautions

l Review the Safety Precautions.
l Determine the placement of each component in the rack before you install the rails.
l Install the heaviest installer components on the bottom of the rack first, and then work
upwards.

l Use a regulating uninterruptible power supply (UPS) to protect the installer from power surges,
voltage spikes and to keep your system operating in case of a power failure.

l Allow the hot plug SATA drives and power supply modules to cool before touching them.
l To maintain proper cooling, always keep the rack’s front door and all panels and components on
the installers closed when not servicing.

Rack Mounting Considerations

Ambient Operating Temperature

If installed in a closed or multi-unit rack assembly, the ambient operating temperature of the rack
environment may be greater than the ambient temperature of the room. Therefore, consider
installing the equipment in an environment compatible with the manufacturer’s maximum rated
ambient temperature (Tmra).

Reduced Airflow

Mount equipment into a rack so that the amount of airflow required for safe operation is not
compromised.

Mechanical Loading

Mount equipment into a rack so that a hazardous condition does not arise due to uneven mechanical
loading.

Circuit Overloading

Consider the connection of the equipment to the power supply circuitry and the effect that any
possible overloading of circuits might have on overcurrent protection and power supply wiring.
Appropriate consideration of equipment nameplate ratings should be used when addressing this
concern.

Reliable Ground

Maintain a reliable ground at all times. To ensure this, the rack itself should be grounded. Pay
particular attention to power supply connections other than the direct connections to the branch
circuit (that is, the use of power strips).

Installing the System into a Rack

This section provides information on installing the Ixia Application Server into a rack unit with the
rack rails provided.

There are a variety of rack units on the market and the assembly procedure may differ slightly. You
should also refer to the installation instructions that came with the rack unit you are using.

Chapter 1  Ixia Application Server Installation
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Identifying the Sections of the Rack Rails

There are two rack rail assemblies in the rack mounting kit. Each assembly consists of two sections;
an inner fixed chassis rail that secures directly to the server chassis and an outer fixed rack rail that
secures directly to the rack itself (see Figure: Inner and Outer Rails). Two pairs of short brackets to
be used on the front side of the outer rails are also included.

Installing the Inner Rails

Both the left and right side inner rails have been pre-attached to the chassis, shown in the following
figure.

Figure: Inner and Outer Rails

Installing the Outer Rails

To install the outer rails, do the following:

1. Measure the distance from the front rail from the front rail to the rear rail of the rack.

2. Attach a short bracket to the front side of the right outer rail and a long bracket to the rear side
of the right outer rail.

3. Adjust both the short and long brackets to the proper distance so that the rail can fit snugly into
the rack.

4. Secure the short bracket to the front side of the outer rail with two screws and the long bracket
to the rear side of the outer rail with three screws.

5. Repeat these steps for the left outer rail.

Both chassis rails have a locking tab, which serves two functions. The first is to
lock the server into place when installed and pushed fully into the rack, which is
its normal position. Second is to lock the server in place when fully extended
from the rack. This prevents the server from coming completely out of the rack
when you pull it out for servicing.

Chapter 1  Ixia Application Server Installation
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Figure: Installing the Inner and Outer Rails

Installing the Server into the Rack

You should now have rails attached to both the chassis and the rack unit. The next step is to install
the server into the rack.

To install the server into the rack, do the following:

1. Line up the rear of the chassis rails with the front of the rack rails.

2. Slide the chassis rails into the rack rails, keeping the pressure even on both sides (you may
have to release the pressure on the locking tabs when inserting).

Chapter 1  Ixia Application Server Installation
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Figure: Installing the Server into a Rack

Installing a Server into a Telco Rack

To install the Ixia Application Server into a Telco type rack, do the following:

1. Use two L-shaped brackets on either side of the chassis.

2. Determine how far follow the server will extend out the front of the rack. Larger chassis should
be positioned to balance the weight between front and back. If a bezel is included on your
server, remove it.

3. Attach the two front brackets to each side of the chassis, then the two rear brackets positioned
with just enough space to accommodate the width of the telco rack.

4. Finish by sliding the chassis into the rack and tightening the brackets to the rack.

Chapter 1  Ixia Application Server Installation
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Figure: Installing the Server into a Telco Rack

Providing Power

The final step is to provide input power to the system. Plug the power cord from the power supply unit
into a high-quality power strip that offers protection from electrical noise and power surges.

It is recommended that you use an uninterruptible power supply (UPS).

System Interface
Figure: Front Panel, Application Server

Chapter 1  Ixia Application Server Installation
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Overview

There are several LEDs on the control panel to keep you constantly informed of the overall status of
the system as well as the activity and health of specific components. There are also two buttons on
the chassis control panel.

Control Panel Buttons

There are two push-button buttons located on the front of the chassis. These are (in order from left to
right) a reset button and a power on and power off button. The front panel controls and indicators are
described in Table: Front Panel Controls & Indicators.

Table: Front Panel Controls & Indicators

Control /
Indicator Description

Reset Reboots the system.

Power Main power switch, which is used to apply or turn off the main system power.
Turning off system power with this button removes the main power but keeps
standby power supplied to the system.

Overheat/
Fan Fail

When this LED flashes it indicates a fan failure. When on continuously, it indicates
an overheat condition, which may be caused by cables obstructing the airflow in the
system or the ambient room temperature being too warm. Check the routing of the
cables and make sure all fans are present and operating normally. Also check that
the chassis covers are installed. This LED will remain flashing or on as long as the
overheat condition exists.

LAN1 When flashing, indicates network activity on LAN1.

LAN2 When flashing, indicates network activity on LAN2.

Chapter 1  Ixia Application Server Installation
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Control /
Indicator Description

HDD Channel activity for all hard disks. When flashing, this light indicates DVD-ROM or
IDE drive activity.

Power (LED) Indicates power is being supplied to the system's power supply units. This LED
should normally be illuminated when the system is operating.

Safety Precautions
Electrical

Basic electrical safety precautions should be followed to protect yourself from harm and the Ixia
Application Server from damage.

l Be aware of the locations of the power on/off switch on the chassis as well as the room's
emergency power-off switch, disconnection switch or electrical outlet. If an electrical accident
occurs, you can then quickly remove power from the system.

l Do not work alone when working with high voltage components.
l Power should always be disconnected from the system when removing or installing main
system components, such as the serverboard, memory modules and floppy drive. When
disconnecting power, you should first power down the system using the operating system and
then unplug the power cords of all the power supply units in the system.

l When working around exposed electrical circuits, another person who is familiar with the
power-off controls should be nearby to switch off the power if necessary.

l Use only one hand when working with powered-on electrical equipment. This is to avoid making
a complete circuit, which will cause electrical shock. Use extreme caution when using metal
tools, which can easily damage any electrical components or circuit boards they come into
contact with.

l Do not use mats designed to decrease static electrical discharge as protection from electrical
shock. Instead, use rubber mats that have been specifically designed as electrical insulators.

l The power supply power cords must include a grounding plug and must be plugged into
grounded electrical outlets.

l DVD-ROM Laser — CAUTION - this server may have come equipped with a DVD-ROM drive. To
prevent direct exposure to the laser beam and hazardous radiation exposure, do not open the
enclosure or use the unit in any unconventional way.

Chapter 1  Ixia Application Server Installation

– 14 –



General Safety Precautions

To ensure general safety, do the following:

l Keep the area around the Ixia Application Server clean and free of clutter.
l The Ixia Application Server weighs approximately 23 lbs to 27 lbs (10.4 kg to 12.2 kg) when
fully loaded. When lifting the system, always keep your back straight and lift with your legs.

l Place the chassis top cover and any system components that have been removed away from the
system or on a table so that they won't accidentally be stepped on.

l While working on the system, do not wear loose clothing such as neckties and unbuttoned shirt
sleeves, which can come into contact with electrical circuits or be pulled into a cooling fan.

l Remove any jewelry or metal objects from your body, which are excellent metal conductors that
can create short circuits and harm you if they come into contact with printed circuit boards or
areas where power is present.

l After accessing the inside of the chassis, close it up and secure it to the rack after ensuring that
all connections have been made.

ESD Precautions

Electrostatic discharge (ESD) can damage electronic components and printed circuit boards. The
following measures are generally sufficient to protect your equipment from ESD.

l Use a grounded wrist strap designed to prevent static discharge.
l Do not let components or PCBs come into contact with your clothing, which may retain a charge
even if you are wearing a wrist strap.

l Handle a board by its edges only; do not touch its components, peripheral chips, memory
modules or contacts.

l When handling chips or modules, avoid touching their pins.

Operating Precautions

Make sure that the chassis cover is in place when the Ixia Application Server is operating, to ensure
proper cooling.

Onboard Battery Replacement

This battery must be replaced only with the same or an equivalent type recommended by the
manufacturer. Dispose of used batteries according to local environmental regulations.

Figure: Onboard Battery Replacement shows the proper orientation of the onboard lithium battery.

There is a danger of explosion if the onboard battery is installed upside down, which will reverse its
polarity.

Chapter 1  Ixia Application Server Installation

– 15 –



Figure: Onboard Battery Replacement

Chapter 1  Ixia Application Server Installation
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CHAPTER 2
Ixia Application Server Settings

Remote Desktop Usage
The Ixia Application Server is designed to be remotely administered via Remote Desktop.

Each remote user is allowed one Remote Desktop session on the Application Server. If a second user
tries to connect to the server with an account that is already logged-in, the original user will be
disconnected. This feature allows a session to be continued at another location if a user forgets to
disconnect.

If a remote user wishes to share his connection with another, use the Assistmode.

In order to leave the session running, but disconnect, use the Disconnect option, but do not log off.
Logging off will kill any running applications for that user. The next connection for the same user
name will continue with the ongoing session.

Logging In to the Ixia Application Server

To log in to the Ixia Application Server via remote desktop, use the two Remote Desktop license
cards pre-installed with the application server.

To install additional RD CALs (Client Access Licenses):

1. Launch the RDS license manager, and select Tools > Terminal Services > Remote
Desktop Licensing Manager in Windows Server 2012.

2. Select the server name and select Install Licences from the context menu.

3. Select the applicable license program and select Next.

4. Enter the licensing information and select Next.

5. Enter the product version, license type, quantity and select Next.

6. Select Finish if the status indicates success.

Ixia will not be responsible for any system failure during installation of
additional RD CALs.

User Account Settings

The following are the default user accounts installed on the Application Server along with their
corresponding passwords. You can access the Application Server using these accounts over Remote
Desktop sessions. These Remote Desktop sessions can be used to install, or uninstall, or modify,
and run applications. It is advised that you change the Admin account names for security reasons.
The default password for the Administrator account should be left unchanged to provide access to
the server for debug purposes.
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The Administrator and Ixia accounts are intended to be used for local console access only. Remote
Access should be done using the Admin and User accounts.

User Account passwords are based on the Chassis Serial Number. For example, if the Serial Number
is 1UAC-123456, then the password is based on 123456.

Table:Single User

Account Name Password

Administrator 123456

Ixia 123456

Admin01 123456-01

User01 123456-01

Table: Multi User

Account Name Password

Administrator 123456

Ixia 123456

Admin01 123456-01

Admin02 123456-02

Admin03 123456-03

Admin04 123456-04

Admin05 123456-05

Admin06 123456-06

Admin07 123456-07

Admin08 123456-08

Admin09 123456-09

Admin10 123456-10

User01 123456-01

User02 123456-02

User03 123456-03

User04 123456-04

Chapter 2  Ixia Application Server Settings
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Account Name Password

User05 123456-05

User06 123456-06

User07 123456-07

User08 123456-08

User09 123456-09

User10 123456-10

Chapter 2  Ixia Application Server Settings
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CHAPTER 3
Running Ixia Applications
Ixia test applications are designed to provide a wide range of innovative test features and
sophisticated testing capabilities. To successfully take advantage of Ixia test applications, use the
Ixia Application Server, which will provide great flexibility in executing test sessions, especially in
circumstances where you need to temporarily disconnect from the test session in progress, and then
reconnect at a later time. Additionally, Ixia applications such as IxNetwork and IxLoad can be
remotely executed on the Ixia Application Server through Microsoft’s remote desktop client.

A properly configured Ixia Application Server running Microsoft Terminal Controller can provide the
following specific benefits:

l Supports multiple users simultaneously
l Requires only a single Ixia test application installation on the application server instead of
installing on all end-user computers

l Frees up the end-user’s computer
l Supports disconnect/reconnect from the test session in progress

Configuration
The Ixia chassis, the Ixia Application Server, and the end-users’ computers are all connected via a
corporate intranet or internet. Ixia test applications will be installed only on the Ixia Application
Server. No installation is required for the individual end-user’s laptop or PC. The end-user’s
computer is used to run the Microsoft Remote Desktop client.

The standard Ixia Application Server can support a single remote user, while the High-Performance
Ixia Application Server can support up to ten simultaneous remote users.

The Ixia Application Server operating system is Microsoft Windows Server 2012 64-bit Standard
Edition with 10 Remote Desktop user licenses.
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Figure: Typical Multi-User Configuration

Multi-User Support

The configuration below supports multiple users running the Ixia application from the High-
Performance Ixia Application Server:

l Each login user needs to have “Administrator” and “Remote Desktop Users” privilege to run the
Ixia application.

l Set the server to restrict each user to single session.
l Only one copy of the Ixia application needs to be installed by a user with an Administrator
privilege. Installation should be done via VNC, not Remote Desktop.

l Each user will be able to execute an Ixia application by running a remote desktop session on the
Ixia Application Server.

l Each user will be able to control and configure his/her own instance of the Ixia application they
are using. Each instance can be modified only by the logged-in user.

l Each instance of the Ixia application and remote desktop session can be viewed and controlled
by other users if permission is granted by the login user. The following quick steps show how to
do this:
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1. On the Server (to which you have connected using Remote Desktop Connection), select Tools
> Terminal Services > RD Licensing Diagnoser in Windows Server 2012. to open the
Terminal Services Manager (Figure: Terminal Services Manager)

Figure: Terminal Services Manager

2. Select RD Licensing Diagnoser. The RD Licensing Diagnoser window appears (Figure: RD
Licensing Diagnoser). Select Connect to Remote Desktop Session Host Server to establish
the remote desktop session.

Figure: RD Licensing Diagnoser

3. After you select Connect to Remote Desktop Session Host Server, the Select Computer
dialog box appears.(Figure: Select Computer) . Select the computer on which you want the
remote desktop session to run and select OK.

Figure: Select Computer
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Now the system is ready to run the Ixia application.

Known Limitations
Installation

l When installing an Ixia application on the Ixia Application Server, only console mode is
allowed. Remote Desktop Session is not able to install all required components (and no error
message will be given). Ixia recommends VNC service to be used for remote installation.

l All Ixia applications need to be terminated before uninstalling/installing any Ixia application.
Failure to do so will cause MSSQL installation error. Ixia recommends to terminate all Remote
Desktop sessions prior to installation.

Any application installed through Remote Desktop will be available to all users
on the server .

IxNetwork

IxNetwork is designed to support the Multi-User function of the Microsoft Terminal Services. The only
limitations are the number of users and chassis supported by a single Application Server. The Multi-
User Support configuration listed above (Multi-User Support) is based on the following requirements:

l There are only 10 simultaneous users
l Each user has 9 to 10 ports on average
l Limit load over routes to 2 instances.
l Each user measures up to 64K traffic flows

The number of measured flows will impact the performance of each user on application server. For
example, when the number of tracked traffic flows for one user reaches 256K, the number of
recommended users on the application will drop to less than six. Ixia recommends to leave 20 -25%
of installed memory available to handle peak demands.

The number of chassis used in the test configuration does not impact the performance of the Ixia
Application Server. However, the number of users, ports, and traffic streams allocated per port will
directly affect the server’s performance. Fewer users on the Ixia Application Server results in larger
configurations available for a single user.
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The default configuration file name is chosen based on user’s login name. For example, the user
Admin01 will use C:\Program Files\Ixia\IxNetwork\data\default_Admin01.ixncfg. The log files are
also stored in a directory based on user’s login name. For example, user Admin01 log files will be
stored in C:\Program Files\Ixia\IxNetwork\admin01\data\logs\.

Default names and locations for trace logs are the same for all users, so it is recommended to change
the names when enabling.

IxAutomate

The saved configuration for IxAutomate, along with its log files and result files, is saved in the same
directory on the Ixia Application Server. The config files for each user will be applied to each instance
of IxAutomate on the application server. Each user must carefully name the config files based on the
user’s login name. For example, the configuration file for user Admin01 could be named RFC2544-
admin01.

The recommended limitation on the number of users, ports, and streams per port is the same as for
IxNetwork.
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