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Notices
Copyright Notice
© Keysight Technologies 2020

No part of this document may be
reproduced in any form or by any means
(including electronic storage and retrieval
or translation into a foreign language)
without prior agreement and written
consent from Keysight Technologies, Inc.
as governed by United States and
international copyright laws.

Warranty
The material contained in this document
is provided “as is,” and is subject to being
changed, without notice, in future
editions. Further, to the maximum extent
permitted by applicable law, Keysight
disclaims all warranties, either express or
implied, with regard to this manual and
any information contained herein,
including but not limited to the implied
warranties of merchantability and fitness
for a particular purpose. Keysight shall not
be liable for errors or for incidental or
consequential damages in connection
with the furnishing, use, or performance
of this document or of any information
contained herein. Should Keysight and the
user have a separate written agreement
with warranty terms covering the
material in this document that conflict
with these terms, the warranty terms in
the separate agreement shall control.

Technology Licenses
The hardware and/or software described
in this document are furnished under a
license and may be used or copied only in
accordance with the terms of such
license.

U.S. Government Rights
The Software is "commercial computer
software," as defined by Federal
Acquisition Regulation ("FAR") 2.101.
Pursuant to FAR 12.212 and 27.405-3 and
Department of Defense FAR Supplement
("DFARS") 227.7202, the U.S. government

acquires commercial computer software
under the same terms by which the
software is customarily provided to the
public. Accordingly, Keysight provides the
Software to U.S. government customers
under its standard commercial license,
which is embodied in its End User License
Agreement (EULA), a copy of which can
be found at
http://www.keysight.com/find/sweula or
https://support.ixiacom.com/support-
services/warranty-license-agreements.
The license set forth in the EULA
represents the exclusive authority by
which the U.S. government may use,
modify, distribute, or disclose the
Software. The EULA and the license set
forth therein, does not require or permit,
among other things, that Keysight: (1)
Furnish technical information related to
commercial computer software or
commercial computer software
documentation that is not customarily
provided to the public; or (2) Relinquish
to, or otherwise provide, the government
rights in excess of these rights
customarily provided to the public to use,
modify, reproduce, release, perform,
display, or disclose commercial computer
software or commercial computer
software documentation. No additional
government requirements beyond those
set forth in the EULA shall apply, except to
the extent that those terms, rights, or
licenses are explicitly required from all
providers of commercial computer
software pursuant to the FAR and the
DFARS and are set forth specifically in
writing elsewhere in the EULA. Keysight
shall be under no obligation to update,
revise or otherwise modify the Software.
With respect to any technical data as
defined by FAR 2.101, pursuant to FAR
12.211 and 27.404.2 and DFARS 227.7102,
the U.S. government acquires no greater
than Limited Rights as defined in FAR
27.401 or DFAR 227.7103-5 (c), as
applicable in any technical data. 52.227-
14 (June 1987) or DFAR 252.227-7015 (b)
(2) (November 1995), as applicable in any
technical data.
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Contacting Us

Ixia headquarters
26601 West Agoura Road
Calabasas, California 91302
+1 877 367 4942 – Toll-free North America
+1 818 871 1800 – Outside North America
+1.818.871.1805 – Fax
www.ixiacom.com/contact/info

Support

Global Support +1 818 595 2599 support@ixiacom.com

Regional and local support contacts:

APAC Support +91 80 4939 6410 support@ixiacom.com

Australia +61-742434942 support@ixiacom.com

EMEA Support +40 21 301 5699 support-emea@ixiacom.com

Greater China Region +400 898 0598 support-china@ixiacom.com

Hong Kong +852-30084465 support@ixiacom.com

India Office +91 80 4939 6410 support-india@ixiacom.com

Japan Head Office +81 3 5326 1980 support-japan@ixiacom.com

Korea Office +82 2 3461 0095 support-korea@ixiacom.com

Singapore Office +65-6215-7700 support@ixiacom.com

Taiwan (local toll-free number) 00801856991 support@ixiacom.com
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Documentation conventions
The following documentation conventions are used in this guide:

Describing interactions with the UI

You can interact with products by using different input methods: keyboard, mouse, touch, and more.
So in most parts of the user documentation, generic verbs have been used that work with any input
method. In cases where input-neutral verbs do not work, mouse-specific verbs are used as the first
choice, followed by touch-specific verbs as the second choice.

See the following table for examples on how you can interpret the different input methods.

Input-neutral Mouse Touch

Select Modify. Click Modify. Tap Modify.

Select Accounts > Other
accounts > Add an account.

Click Accounts > Other
accounts > Add an account.

Tap Accounts > Other
accounts > Add an account.

To open the document in Outline
view, select View > Outline.

To open the document in
Outline view, click View >
Outline.

To open the document in
Outline view, tap View >
Outline.

Select Protocols. Click the Protocols tab. Tap Protocols.

-NA- Double-click the Client wizard. Double-tap the Client wizard.

Open the Packages context
menu.

Right-click Packages to open
the shortcut menu.

Long tap Packages to open
the shortcut menu.

Deprecated words

The following words have been replaced with new words, considering the audience profile, our modern
approach to voice and style, and our emphasis to use input-neutral terms that support all input
methods.

Old usage... New usage...

shortcut menu, right-click menu context menu

click, right-click select

drag and drop drag

Documentation conventions
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CHAPTER 1 Introduction to Analyzer
The purpose of this chapter is to provide a short overview on the product regarding its architecture and
layout.

About Analyzer
Analyzer is a powerful Network Traffic Analyzer that captures the traffic on the IXIA ports and provides
a lot of statistics, measurements, diagrams, and application viewers to help you debug network
problems. It is built as an APTIXIA module and it provides an API to enable other applications to
control the network capture.
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CHAPTER 2 Analyzer Navigation
This chapter provides a description of the Analyzer Graphical User Interface, allowing you to easily
navigate through the application, by using:

Main Window below

Menus and Tool Bars on page 5

Opening a Capture in Analyzer on page 9

Main Window
The main window consists of four main panels, as shown in the following figure:

l Navigation View– Contains the details of the Live and Offline captures.
l Common View – Contains view specific tabs. It contains more detailed information than the main
list, and makes available various statistics related to the main list selection.

l Capture for Ports View – Contains detailed packet information of the ports.
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Section Fields/Controls Description

1.
Navigation
View

Provides details on both Live and the Offline captures.

2.
Common
View

Port State The current state of the port, Up or down.

Port Name The name of the port present in the test.

Port Captures Signifies the number of captures per port while configuring
manually.

Control - Enable Select this to turn on the capture for the specific port. By
default, it is not selected.

Control - Filter Set a custom filter for the port. The filter is configured by using 
filter string expressions from the tcpdump application. The filter 
can be introduced manually or by using the Pattern Editor. By 
default, it is set to None. This tab is available only when the 
Control tab is selected.

Control - Partial
Capture

Specify the maximum amount of data that is captured for each
packet. If partial capture is selected, the following message
appears in Wireshark: “packet size limited during capture”. By
default, it is set to Capture full supported. This tab is
available only when the Control tab is selected.

3. Capture
for Ports
view

Capture Name The name of the capture for the test.

Started The start time of the capture, denoted by time and date stamp.

Ended The time when the capture has ended, denoted by time and
date stamp.

Duration The duration for which the capture has successfully run.

Chapter 2  Analyzer Navigation
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Section Fields/Controls Description

Packets The number of packets that are actually transferred from the
ports to the GUI. The increase rate here is much slower than
Captured. If you select, Abort packet upload, the packet
transfer from port to GUI stops immediately, and only the
packets which were transferred before the abort operation are
present in the GUI. You have a link on the number of packets,
which on selection opens up wireshark and shows you the
packets in the GUI.

Captured The number of packets that are captured in the port. These
packets are transferred slowly over time to the GUI.

Dropped The number of packets which the Analyzer was not able to
capture on the port due to a high scale test.

Menus and Tool Bars
This section describes the Analyzer menu options and tool bar buttons:

Packet Capture Menu
List details related to Open Capture, Grid Operations, Merge Capture etc.

Reports Menu

Open Capture

Gives the option to open an existing Capture.

Save and Close

Save button allows you to save the current opened capture(s). Close button allows you to close the
selected capture.

Chapter 2  Analyzer Navigation
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Close All allows you to close all displayed captures.

Merge Capture

Analyzer has the option of merging two captures.

1. Type the path to the first file to merge in the First capture field. Alternatively, you can select

to indicate the file’s location.
2. Type the path to the second file to merge in the Second capture field. Alternatively, you can

select to indicate the file’s location.
3. Type the path for the result file in the Destination capture field. Alternatively, you can select

to indicate where you want the file to be saved.
4. Optionally, you can select Open resulted capture to automatically open the result file after the

merging process is complete.

Select OK to merge two files.

Note: Two captures of different types cannot be merged. Both of them must be, for example,
Ethernet, or both ATM, and so on. Also, the result file cannot exceed 4 GB.

Chapter 2  Analyzer Navigation
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Capture Settings

Capture Settings allows you to configure the following global parameters for Analyzer:

l Capture Run Mode,
l Capture View Display Mode
l Buffer full behavior
l Capture View Buffer Size
l Custom External Viewer

Chapter 2  Analyzer Navigation
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Section Fields/Controls Description

Note: The settings can be changed only after the test is stopped and Release configuration
per port is complete.

Capture
Run
Mode

Automatic (match
apply config and test
duration)

Starts the capture automatically once the test start.

Manual Manually capture packets throughout the duration of the
test. Need to select Start Capture to start capturing
packets.

Start with a delay of
(HH:MM:SS) ...
running for ...

Configure the exact time after which the capturing of packets
needs to start and also mention for how long the capture
needs to take place, by mentioning the duration in Hour,
minutes and seconds.

Capture
View
Display
Mode

Stream (real-time
capture)

The transfer of captured packets starts immediately from the
ports to the GUI.

Upload capture
packets after capture
stops

The transfer of the captured packets to the GUI starts only
after the capture has stopped in the port.

Buffer
Full
behavior

Stop capture When the memory buffer is full on the port, stop capturing
any more packets from the test.

Overwrite oldest
packets (circular
buffer)

When the memory buffer is full on the port, replace the
oldest packets with the newer ones.

Capture
View
Buffer
Size

Memory allocated for
the capture buffer per
port (% of the
available memory)

The size of the memory buffer for capturing packets per port.

Custom
External
Viewer

Use Ixia Wireshark Use the Ixia wireshark version which gets installed, when
you install IxLoad.

Chapter 2  Analyzer Navigation
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Section Fields/Controls Description

Use Custom
Wireshark

Use the custom wireshark version pre-installed in your
computer. Navigate to the required path and select the .exe
file.

Opening a Capture in Analyzer
To open a capture in Analyzer:

1. Select File > Open in the main menu, or click the Opentool bar button. The Open...dialog
opens.

2. In the Files of type list, select one of the two options:
l Capture file (*.cap) – used to open an existing capture
l Live capture file (*.lcap) – used to open a live capture that is being performed by using the
application with which the Analyzer is integrated.

3. Browse for the capture file, select it, then click Open. The capture displays in the Analyzer main
view.

You can have more than one capture opened at a time in Analyzer and navigate between them by
selecting the corresponding capture.

Chapter 2  Analyzer Navigation
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